Сбор статистики скорости своего канала с общедоступного сервера
:global itx; :global irx; /tool bandwidth-test 207.32.194.24 user=btest password=btest direction=both duration=30s do={:if ($status="running") do={:set itx $"tx-current"; :set irx $"rx-current"}}
остается передать переменные itx irx по почте и обработать их
а если провайдера 2, то программно создаем правило для скрипта а потом его удаляем.....
:global itime [/system clock get time];
:global idate [/system clock get date];
:global itx -1; :global irx -1; /tool bandwidth-test 207.32.194.24 user=btest password=btest direction=both duration=30s do={:if ($status="running") do={:set itx $"tx-current"; :set irx $"rx-current"}}
/ip route add dst-address=207.32.194.24 gateway=eth2_sky_pptp58 comment="temporary";
:global itx2 -1; :global irx2 -1;
/tool bandwidth-test 207.32.194.24 user=btest password=btest direction=both duration=30s do={:if ($status="running") do={:set itx2 $"tx-current"; :set irx2 $"rx-current"}}
/ip route remove [find comment="temporary"];
а затем при помощи письма отсылаем для обработки....
global itx
global irx
global idate;global itime
/tool e-mail send to="test@test.ok" subject=("west12_bandwith") body=("bwstart\n".$idate."\n".$itime."\nwest12\nbandwidth\nrx:".$irx."\ntx:".$itx."\nbwstop");
global itx2;
global irx2;
/tool e-mail send to="test@test.ok" subject=("sky58_bandwith") body=("bwstart\n".$idate."\n".$itime."\nsky58\nbandwidth\nrx:".$irx2."\ntx:".$itx2."\nbwstop");
:global itx; :global irx; /tool bandwidth-test 207.32.194.24 user=btest password=btest direction=both duration=30s do={:if ($status="running") do={:set itx $"tx-current"; :set irx $"rx-current"}}
остается передать переменные itx irx по почте и обработать их
а если провайдера 2, то программно создаем правило для скрипта а потом его удаляем.....
:global itime [/system clock get time];
:global idate [/system clock get date];
:global itx -1; :global irx -1; /tool bandwidth-test 207.32.194.24 user=btest password=btest direction=both duration=30s do={:if ($status="running") do={:set itx $"tx-current"; :set irx $"rx-current"}}
/ip route add dst-address=207.32.194.24 gateway=eth2_sky_pptp58 comment="temporary";
:global itx2 -1; :global irx2 -1;
/tool bandwidth-test 207.32.194.24 user=btest password=btest direction=both duration=30s do={:if ($status="running") do={:set itx2 $"tx-current"; :set irx2 $"rx-current"}}
/ip route remove [find comment="temporary"];
а затем при помощи письма отсылаем для обработки....
global itx
global irx
global idate;global itime
/tool e-mail send to="test@test.ok" subject=("west12_bandwith") body=("bwstart\n".$idate."\n".$itime."\nwest12\nbandwidth\nrx:".$irx."\ntx:".$itx."\nbwstop");
global itx2;
global irx2;
/tool e-mail send to="test@test.ok" subject=("sky58_bandwith") body=("bwstart\n".$idate."\n".$itime."\nsky58\nbandwidth\nrx:".$irx2."\ntx:".$itx2."\nbwstop");
Комментариев нет:
Отправить комментарий